No inicia XAMPP en Windows 7

Después de instalar XAMPP en Windows 7 y al presionar el botón start lo normal es que se pueda observar de color verde la palabra Running, así como se presenta en la gráfica, sin embargo aparece por unos segundos y desaparece, ese es el error que se me presentó.

startXAMPP

Me acordé que en una instalación que realicé hace tiempo se me presentó el mismo problema, debido a que tenía instalado IIS.  La solución fué cambiar de puerto a apache y listo!  Ese mismo procedimiento lo he probado en Win7 y funciona de maravilla.  La solución es la siguiente:

1. Buscar en la carpeta de instalación de XAMPP la siguiente ruta:

2. Localizar el archivo de configuración httpd.conf:

3. Hacemos clic derecho sobre el mismo, elegimos la opción de abrir y en el diálogo que nos aparezca seleccionamos la opción seleccionar un programa de la lista y presionamos aceptar:

4.  Ahora en la lista seleccionamos BLOCK DE NOTAS y presionamos aceptar:

 5. Finalmente se busca la línea en la cual se indica el puerto que esta usando XAMPP que es el 80 y lo cambiamos por el 8080 por ejemplo.

Antes:   Listen 80   Después: Listen8080

 Así como se muestra en la imágen:

 Para terminar, se guardan los cambios y se vuelve a iniciar el servidor y listo!  Si ese es su problema, XAMPP debería funcionar correctamente…

Para comprobar que funciona adecuadamente se debe ir al navegador y escribir la siguiente dirección:

Y al presionar enter se presenta la pantalla que indica que fué instalado correctamente el servidor. 😀

12 comentarios

  1. muchas gracias

  2. excelente!!!!
    , gracias

  3. Muy clara la explicacion, cambie el puerto como dicen y me funciono el Apache

  4. ami no me funciono no consigo iniciarlo :S
    dice busy…

  5. a mi tampoco me funciono, no consigo lograr iniciar, me sale, como corriendo el apache pero al intentar ingresar a localhost no me sale nada

  6. gracias pero y para activar mysql tampoco me va.

  7. Muy Bueno Gracias!!!

  8. Gracias funciono perfectamente!!!

  9. de esta manera no me funcionó, lo que hice fue que desinstalé el programa, luego le di clic derecho al archivo .exe le di donde dice solucionar problemas de compatibildad seguí todas las indicaciones y funcionó perfecto sin tener que modificar nada

  10. Gracias Bro por el detalle de sacar de la duda

  11. Ahora voy a cambiar de puerto y espero que con la ayuda de Dios funcione correctamente…..
    y gracias de antemano…….

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: